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 Preamble 

This document describes the MobileNAV installation process. The installation of the MobileNAV solution 

starts with preparation. The preparation checklist contains certain pre-requisites and decisions which have 

to be made before the actual MobileNAV installation takes place. The installation process is described in 

details in in the Installing MobileNAV solution chapter of this guide. 

 Preparation checklist 

1. Signed MobileNAV Partner Contract 
In order to sell, install or configure the MobileNAV solution, you need to sign the MobileNAV Partner 

Contract. After MultiSoft receives the signed contact, we grant you access to the MobileNAV granule in 

VOICE.  

2. Update NAV developer license with MobileNAV granule 
Make sure that your NAV developer license contains the MobileNAV granule (42012830). When you 

become an official MobileNAV partner, you can update your developer license in the Partner Source.  

For detailed instructions, see the MobileNAV - How-to order MobileNAV granule document. 

3. Order MobileNAV granule into customer’s NAV license 
Order the MobileNAV granule into your customer’s NAV license as follows: 

1. Go to Microsoft Partner Source portal: https://mbs.microsoft.com/partnersource/ 

2. Search and select your customer 

3. In the Order Catalog, find the MobileNAV granule (42012830). 

https://mbs.microsoft.com/partnersource/
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4. Order this granule into your customer’s NAV license. 

5. Download the new customer NAV license. 

6. Check whether it contains the MobileNAV granule: 

a. open the license file in Notepad. 

b. find 42012830 MobileNAV granule 

 

 
 

7. Upload the new license into the NAV database. 

For detailed instructions, check the “MobileNAV - How-to order MobileNAV granule” document. 

4. Order MobileNAV Client App Licenses from MultiSoft 
Order a proper MobileNAV Client App License from MultiSoft by providing the following information: 
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- your Microsoft VOICE Account Number 

- your customer’s Microsoft VOICE Account Number 

- how many device licenses you want to order 

- type of the license 

o internal-use: the partner would like to use this license for demo/development purposes 

o trial license for customer: the customer would like to try out the MobileNAV solution for a 

limited time period (1 month) 

o normal license for customer: a standard license for the customer. In this case MultiSoft will 

invoice the partner for the licenses (decreased by the margin of the partner) 

MultiSoft generates and sends over the requested MobileNAV license. 

5. Select a deployment scenario 
Decide how the mobile device will access your NAV server. You need to make sure, that mobile users will 

be able to connect to the NAV server from external network not only from the intranet. If you do not have 

such an issue in your installation, because, for instance, you will use MobileNAV in a warehouse with 

intranet Wi-Fi, then you can skip this step of the installation.  

The MobileNAV client needs access to the web services from the mobile device. Depending on the 

Dynamics NAV deployment scenario, the web service can be accessed in several ways. The most common 

methods are listed below: 

5.1. Directly exposed web services 

In this scenario the web service is directly exposed to the web, which means that the web service port of 

the Service Tier on the server can be accessed directly from the Internet. This also means that the server 

has a public IP address (not an internal one), predominantly when the NAV server is hosted somewhere. 

5.2. Internal server, VPN  

In this case the NAV Service Tier is installed in the domain, and it is only accessible on the company domain. 

To be able to access the web services outside of the domain, the device must establish VPN connection. 

When VPN connection is established, the MobileNAV client can access the internal web services without 

restrictions. This scenario is easy to do from IT administration point of view, because in most cases the 

companies already have VPN connection for their external/off-site employees. The disadvantage of this 

solution is that it is not really convenient for MobileNAV users, because they need to make sure that the 

VPN connection is established before they start working with MobileNAV. 

5.3. Internal server, Port forwarding 

In this case the NAV Service Tier is installed in the domain, and, as a result, it does not have a public IP 

address, but port forwarding is configured on the router or on the firewall. This means that the web service 

port of NAV is made available outside the domain, and it can be accessed directly from an external device. 

Port forwarding is a well-known practice for IT Administrators. Since the web service is XML based, and it 

uses SOAP over HTTP protocol, the port forwarding rule can be protected with an HTTP or a SOAP over 
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HTTP rule. Therefore the router or firewall will only forward those messages that match the filter rule, 

which depends on the capabilities of the router or firewall. In this scenario, the client does not have to 

establish VPN connection, but the external IP address (or friendly URL) has to be provided for the server. 

6. Service Tier installation 
The Service Tier of NAV provides web service access to NAV data and functionality. In this step you need to 

make sure that the Microsoft Dynamics NAV Web Server components installed on a computer that is 

running Internet Information Services (IIS) and configured properly for NAV.  

Dynamics NAV version requirements: 

- Dynamics NAV 2013: no Cumulative Updates needed. Compatible with base build, or above 

- Dynamics NAV 2013 R2: no Cumulative Updates needed. Compatible with base build, or above 

- Dynamics NAV 2015: no Cumulative Updates needed. Compatible with base build, or above 

- Dynamics NAV 2016: no Cumulative Updates needed. Compatible with base build, or above 

- Dynamics NAV 2017: no Cumulative Updates needed. Compatible with base build, or above 

- Dynamics NAV 2018: no Cumulative Updates needed. Compatible with base build, or above 

- Dynamics 365 Business Central: no Cumulative Updates needed. Compatible with base build, or 

above 

7. Service Tier configuration 
During the Service Tier setup you may already set certain configuration parameters, but you can also 

change them later on: 

After you install Microsoft Dynamics NAV Server, you can change any of the settings you provided during 

Setup using either the Microsoft Dynamics NAV Server Administration tool or the Microsoft Dynamics NAV 

PowerShell cmdlets for Microsoft Dynamics NAV 2013. 

You can configure by directly editing CustomSettings.config, the Microsoft Dynamics NAV Server 

configuration file. By default, this file is located in C:\Program Files\Microsoft Dynamics 

NAV\<version>\Service\Instances\<instancename>. In 64 bit operating systems, this 

component located separately in the 64bit program files folder. We recommend that you do not directly 

edit the configuration file, because if you mistype anything, you may not be able to start the instance. 

For detailed description about settings, see Configuring Microsoft Dynamics NAV Server 

 

7.1. Web service port 

By default the web service port is 7047, which you can modify. Find the "SOAP services/Port" key in the 

server administration tool, and change the value as necessary. 

http://msdn.microsoft.com/en-us/library/dd355055(v=nav.70).aspx
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Setting the web service port is quite important, if you want to connect to your NAV server from different 

locations. Firewalls normally permit specific ports, such as 7047. By changing the web service port to a 

commonly used one, like: 80 or 8080, then you can make sure that your firewall will not cause connection 

problems. 

7.2. SSL configuration 

You can configure the Service Tier to use SSL encryption for the communication channel. Secure Sockets 

Layer (SSL) is a cryptographic protocol that provides security and data integrity for data communication 

over a network. By encrypting your Microsoft Dynamics NAV 2013Web services with SSL, you make your 

data and your network more secure and more reliable. 

For detailed instructions check Walkthrough: Configuring Web Services to Use SSL (SOAP and OData) 

7.3. NTLM authentication 

The web service is not configured to use NTLM authentication by default, therefore you have to modify it. 

Find the "WebServicesUseNTLMAuthentication" key in the server administration tool, and change the value 

to “true”. 

You must choose Edit in the Microsoft Dynamics NAV Server Administration tool before you can modify any 

values. 

 

 

http://msdn.microsoft.com/en-us/library/ee414240%28v=nav.70%29.aspx
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8. Creating Users inside NAV for MobileNAV users 
Each MobileNAV user must be granted access in NAV. You can create Windows Accounts, you can also use 

NAVUserPassword users, or users with Office 355 Authentication inside NAV. In eash cases the proper 

rights should be applied for these users. 

Although Automatic synchronization takes place when you insert, modify or delete a Windows login in 

Standard Security model. When you are running with the Enhanced Security model, there is no automatic 

synchronization. 

Remember, if you use Windows Accounts as users, then the Service Tier to which you want to connect your 

MobileNAV users should have Credential Type = Windows or UserName. If you use NAVUserPassword users 

for MobileNAV, then the Service Tier to which you want to connect your MobileNAV users should have 

Credential Type = NAVUserPassword accordingly. 

This approach has several benefits: 

- the security system of NAV will be applied to MobileNAV users as well 

- the MobileNAV users will be distinguishable in NAV (in C/AL code) 

- NTLM authentication can be used with web services, which is an industry standard 

For detailed instructions, see How to: Create Microsoft Dynamics NAV Users and How to: Define 

Permissions for Users. 

9. Check Service Tier and web services on the server computer 
You must check, whether you installed and configured the Service Tier properly, so that the web service 

interface is working: 

1. Go to Services, and find the Service Tier service. In NAV 2013 or above version there is only one 

service, which is called “Microsoft Dynamics NAV Server”. 

 

2. Restart the service. 

3. Make sure the service is started properly. 

http://msdn.microsoft.com/en-us/library/dd355093(v=nav.70).aspx
http://msdn.microsoft.com/en-us/library/dd338839(v=nav.70).aspx
http://msdn.microsoft.com/en-us/library/dd338839(v=nav.70).aspx
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4. Go to Event Viewer, and check whether the service is properly started, and that there is no error as 

shown below: 

 

 
 

5. Copy the http address from the event description, and paste it into a browser. 

 

Note: The web service URL is put together like this: 

http://{computer name}:{web service port}/{instance name}/WS/Services 

 

6. If the web service is working properly, a Windows Security dialog is displayed. 

 

7. Enter one of the MobileNAV windows accounts, that you have configured previously, and click OK.  

8. The result in the browser is shown below: 
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Note: To ensure that all MobileNAV users can access the server, you may repeat the instructions 

starting from Step 5. 

10. Check Service Tier and web services in a browser from an external 

network 
You should test the accessibility of the previously defined URL address from an external network, such as a 

mobile network or an external Wi-Fi. In this way, you can make sure that web services are accessible 

through domain firewalls or routers. Depending on your deployment scenario, you may have to replace the 

computer name for the external address of the server PC. For example, if you decide to use an internal 

server with port forwarding, then you need to replace the computer name with the external IP address as 

follows: 

1. If you have chosen an internal server with VPN connection, then connect via VPN from the external 

computer. 

2. Open a browser, and enter the URL of your server. In our test environment we have a 

gateway/firewall with the following friendly name: gw6.multisoft.hu. It is an SSL-enabled server, 

and our instance name is “MNTest”, therefore the modified URL is: 

https://gw6.multisoft.hu:7047/MNTest/WS/Services 

https://gw6.multisoft.hu:7047/MNTest/WS/Services
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3. Provide the windows login credentials of one of your MobileNAV users, you have set up. 

 

4. Verify that there are no errors, and that the services run as described above. 

5. For peace of mind, you can repeat these steps for each MobileNAV user you have set up. 

11. Check Service Tier and web services with SOACleaner 
Use a web service testing tool that not only tests the WSDL of the web services, but can also try to retrieve 

data from the web services: 

1. Download SOACleaner from http://xyrow.com. 

2. Launch SOACleaner.exe and click Start SOA Cleaner Express. 

http://xyrow.com/
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3. Go to Settings -> Credentials, select the Define Windows Credentials option, and enter the proper 

username, password and domain.  

 
4. Click OK. 

5. Enter the previously used URL into the WSDL field, and at the end of the URL, change “/Services” to 

“/SystemService”. In our example the URL is the following: 

https://gw6.multisoft.hu:7047/MNTest/WS/SystemService  

 

https://gw6.multisoft.hu:7047/MNTest/WS/SystemService


 13/57 MobileNAV Installation Guide 

 

 
6. Click Load. 

 
The web service is loaded, and in the Operation drop-down list you should find “Companies”, which 

is a standard web service that returns the available company names from the database. 

7. Click Invoke at the bottom of the window to invoke the web service. All available companies are 

listed in the response on the XML View tab. 
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IMPORTANT 

Please do not continue until this test has been successfully executed. This test is not related to the 

MobileNAV solution, since it is using the built-in web service of NAV. IT Administrators should be able to 

resolve any problems, and with this tool they can gather sufficient information for the resolution. 

12. Check Service Tier and web services from mobile device 
In this task you will validate the previous URL address from a mobile device, so that you can make sure that 

the mobile device is able to communicate with the web services. Depending on your deployment scenario, 

you may have to replace the computer name for the external address of the server PC. For example if you 

decide to use an internal server with port forwarding, then you have to replace the computer name with 

the external address as follows: 

1. If you have chosen internal server with VPN connection, then connect via VPN from the mobile 

device. 

2. Open a browser, and enter the URL address of your server. 



 15/57 MobileNAV Installation Guide 

 

 

3. Provide the windows login credentials of one of your MobileNAV users, you have set up 
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4. Verify that no error occurs 

5. For peace of mind, you can repeat these steps for each MobileNAV user you have set up. 

 Installing MobileNAV solution 

1. Install MobileNAV Component setup 
MobileNAV has a separate DLL component for licensing. This component must be installed on the PC where 

the Service Tier is installed and running. Furthermore, you need to install MobileNAV on the PCs, where you 

want to use Development Environment for compiling MobileNAV related Add-on objects. 

To install the MobileNAV component, follow the instructions below: 

1. Run setup.exe or DllSetup.msi in the MobileNAV installation package. 

 

 
 

2. Click Next. 

3. Choose the installation folder. 
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4. Click Next. 

 

 
 

5. Confirm the installation, and click Next. 

6. If administrative rights (UAC) are necessary for the installation, then allow those as well. 
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The installation starts 

7. Make sure that it finished without errors. 

 

8. Validate the installation by checking the installation destination folder content, which is 

“C:\Program Files (x86)\MultiSoft Kft\MobileNAV Components 2.0” by 

default. Its content is shown below: 
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2. Import MobileNAV Add-on objects 
In this step you will import the MobileNAV Add-on granule objects as follows: 

1. Launch NAV Development Environment, and open the proper database and company. 

2. Go to the File -> Import… menu. 

3. Select the MobileNAV Add-on .fob from the installation package. 

4. Choose Yes to import all objects, or choose No to launch the Import Worksheet where you can 

review the objects to be imported. 

 

5. Click OK. 

The objects will be imported. 

 
 

6. Click OK to confirm that all objects have been successfully created (there are 51) in version 4. 
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3. Apply MobileNAV standard object modifications for base configuration 
There are a few modifications, or coding convention for the MobileNAV solution, which must be applied to 

use those objects in MobileNAV. These are mainly simple C/AL code modifications because of the web 

service usage. When a trigger or function is executed via web services, it is not possible to display 

messages, warnings, and so on. These UI interactions must be avoided when the C/AL code is executed via 

web services. The best way of doing this is to use the GUIALLOWED global property of NAV, which is set to 

TRUE if it is running on RTC client, and it is set to FALSE, if it is executed from a web service. 

For more information about this topic, see Handling UI Interaction When Working with Web Services 

These objects might need to be modified (depending what you are planning to use from the base 

configuration): 

• Table 37 – Sales Line: If you use Reservation feature of Dynamics NAV, and you want to be able to 

use Sales Lines within MobileNAV, then you need to escape showing the standard Reservation 

window of NAV, because it is not possible to open it from web services. In order to use Sales Line 

with Reservation, we have to escape showing the Reservation windows with GUIALLOWED. 

o Note: If you are not planning to use Sales Line with Reservation in MobileNAV, you don’t 

need to merge this. 

• Table 5080 – To-do: When you create a new To-do in the mobile application, the Type validation 

will run after inserting a method. For example, if you want to use Meeting for to-do type, then the 

original code generates an error message since changing the type from blank to meeting is not 

permitted. Therefore a new function is necessary, which will set a boolean variable. This variable 

will tell the system not to validate the type on insert method, but it will be validated after insertion. 

You have to call the new function with the OnNewRecord and OnInsertRecord triggers on the 

MNToDoCard page.  

o Note: If you are not planning to use To-do’s in MobileNAV, you don’t need to merge this. 

• Table 5199 – Attendee: When you create a new Attendee for a To-Do in a mobile application, the 

standard ValidateAttendee function runs on insert method. It generates a validation error, because 

the Attendee No. is missing on the insert method. A new function is necessary, which will set a 

boolean variable. This variable will tell the system not to run the ValidateAttendee function on 

insert method. Instead, ValidateAttendee will run on modifiy method. You have to call the new 

function with the OnNewRecord and OnInsertRecord triggers on the MNAttendeeCard page.  

o Note: If you are not planning to use To-do’s in MobileNAV, you don’t need to merge this. 

http://msdn.microsoft.com/en-us/library/dd301080.aspx
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• Table 5767 – Warehouse Activity Line: you need to make the "UpdateBreakbulkQtytoHandle" 

method to Public = Yes for MobileNAV usage. This is used on warehouse related documents, like 

Pick, Put-away or Movement. 

o Note: If you are not planning to use Pick, Put-away or Movement in MobileNAV, you don’t 

need to merge this. 

• Table 5902 – Service Line:  

o When using Component Replacement on a Service Line, there is a standard method 

(CheckIfServItemReplacement), what the base configuration needs to invoke, but it is 

LOCAL. We need to make it public. 

▪ Note: If you are not planning to use Service Line with Component Replacement in 

MobileNAV, you don’t need to merge this. 

o If you use Reservation feature of Dynamics NAV, and you want to be able to use Service 

Lines within MobileNAV, then you need to escape showing the standard Reservation 

window of NAV, because it is not possible to open it from web services. In order to use 

Service Line with Reservation, we have to escape showing the Reservation windows with 

GUIALLOWED. 

▪ Note: If you are not planning to use Service Line with Reservation in MobileNAV, 

you don’t need to merge this. 

• Codeunit 241 – Item Jnl.-Post: When we post Item Journal Lines in Warehouse or Manufacturing 

module, then we use this standard codeunit. In order to invoke it from the web service we have to 

escape the CONFIRM or MESSAGE lines with GUIALLOWED. 

o Note: If you are not planning to post Item Journals in MobileNAV, you don’t need to merge 

this. 

• Codeunit 1013 – Job Jnl.-Post Batch: When we post Job Journal Lines in Job module, then we use 

this existing CU. In order to invoke it from the web service we have to escape the CONFIRM, 

Window.UPDATE or MESSAGE lines with GUIALLOWED. 

o Note: If you are not planning to post Job Journals in MobileNAV, you don’t need to merge 

this. 

• Codeunit 5510 - Production Journal Mgt: When using the Production Journal from MobileNAV, the 

DeleteJnlLines method is required, but it is a LOCAL method in this codeunit. We need to make it 

public. 

o Note: If you are not planning to use Production Journal in MobileNAV, you don’t need to 

merge this. 

• Codeunit 6501 – Item Tracking Data Collection: In order to utilize the Item Tracking in MobileNAV 

base configuration, you need to add/merge only one method (GetEntrySummary) to the codeunit. 

o Note: If you are not planning to use Item Tracking in MobileNAV, you don’t need to merge 

this. 

• Page 6510 – Item Tracking Lines:  In order to utilize the Item Tracking in MobileNAV base 

configuration, you need to add/merge only two methods (GetTotalItemTrackingLine and 

SetTempItemTrackLineInsModDel) to the page code.  
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o Note: If you are not planning to use Item Tracking in MobileNAV, you don’t need to merge 

this. 

• Report 204 – Sales - Quote: when you print Sales Quote PDF, then NAV ask for creating follow-up 

To-Do, but confirmation messages should be escaped with GUIALLOWED flag. 

o Note: If you are not planning to print Sales Quote PDF in MobileNAV, you don’t need to 

merge this. 

• Report 7305 - Whse.-Source - Create Document: when you use Ad-hoc Movement feature of 

MobileNAV, it creates Warehouse Movement document with this standard codeunit. To 

immediately register the newly created Warehouse Movement, we need a new method called 

GetActivityNos to be able to query the newly created Warehouse document’s No.  

o Note: If you are not planning to use the Ad-hoc Movement in MobileNAV, you don’t need 

to merge this. 

 

Apply these modifications as follows: 

1. Launch Development Environment client, and open the proper database and company. 

2. Open Object Designer (SHIFT + F12). 

3. Go to the File -> Import… menu. 

4. Browse the StandardObjectCustomizations .fob from the installation package. 

5. Choose Yes to just import all objects, or choose No to launch the Import Worksheet where you can 

review the objects to be imported. 

 

6. Click OK. 

The objects will be merged. 

7. Confirm that each license object has been successfully merged. 
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Note: if these objects have already been modified or customized, then you should apply these 

modifications manually. 

4. Import MobileNAV Configuration objects (pages, codeunits) 
Import the configuration related objects, like pages and codeunits. You can either import your 

own/customized configuration objects, or import the base configuration provided by MultiSoft. Either way, 

the procedure is similar as described below: 

1. Launch Development Environment client, and open the proper database and company. 

2. Open Object Designer (SHIFT + F12). 

3. Go to the File -> Import… menu. 

4. Browse the MobileNAV Configuration Objects .fob from the installation package. 

5. Choose Yes to just import all objects, or choose No to launch the Import Worksheet where you can 

review the objects to be imported. 

 

6. Click OK. 

The objects will be imported. 
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7. Confirm that all objects have been successfully created. 

 

8. Recompile every MobileNAV Configuration objects. 

a. In Object Designer, select All category on the left panel. 

b. Apply Table Filter for Version List field, and set “*MNCO*” as filter. 

c. Select all objects in the list. 

d. Re-compile the selected objects (F11). 

 

 

 

5. Compile MobileNAV objects 
 

1. Recompile every MobileNAV objects: 

a. In Object Designer select the All category on the left panel. 
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b. Apply Table Filter for the Version List field, and set “*MN*” as filter. 

c. Select all objects in the list. 

d. Re-compile the selected objects (F11). 

 

 
 

2. Recompile every MenuSuite objects: 

a. In Object Designer, select the MenuSuite category on the left panel. 

b. Do not apply any filter. 

c. Select all objects in the list. 

d. Re-compile the selected objects (F11). 
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6. Set up MobileNAV with Assisted Setup  
You can set up MobileNAV with an Assisted Setup, which drives you thru the necessary steps, or you can 

execute the necessary steps individually. 

In this step you will execute the Assisted Setup for MobileNAV. 

1. Launch Dynamics 365 Business Central SaaS, and log in with your account 

2. Press ALT + Q for quick search Assisted Setup 

 

 
  

3. Select the “Set up MobileNAV” Assisted Setup  
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4. Welcome screen: Press Next 
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5. MobileNAV License: Press Start Trial Period to start a trial period for 30 days with 5 devices or 

press Import License to import your MobileNAV License String you got from your Dynamics 365 

Business Central partner or from MobileNAV Sales Team. 

 

 
 

 

6. MobileNAV Configuration: Press Import Config and decide whether you want to import the Base 

Configuration of MobileNAV, or you would like to import a customized MobileNAV Configuration 

XML. In the second case, you need to browse the custom configuration XML file, and then the 

import will be started. 
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7. MobileNAV Users: in this step you can set up users for MobileNAV. First you need to choose an 

already existing user in Dynamics 365 Business Central. Please note that setting up the users in 

Dynamics 365 Business Central should be done prior this step. 
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After selecting the user, you need to assign a MobileNAV profile to the user.  

 

In case you have imported the base configuration, you will see a “simplified” profile selector, where 

you need to select a profile (like Sales, Service, etc.), and a Login Mode (like Online, Offline or Auto 

Online/Offline).  

 

 
 

In case you have imported a custom configuration, then you will see a slightly different screen, 
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where you need to assign at least one Profile, and after that you can press the Set up User where 

you can do the rest of the User Setup, like select Login Mode, etc. 

 

 
 

8. If you want to set up additional users, press New User, or press Finish to finish the Assisted Setup. 

 

 

7. Set up MobileNAV “manually” 
You can set up MobileNAV with an Assisted Setup, which drives you thru the necessary steps, or you can 
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execute the necessary steps individually. 

These steps are the following: 

• Import MobileNAV License String 

• Import MobileNAV Configuration 

• Set up MobileNAV Users 

7.1. Import MobileNAV License String 

In this step you will import the MobileNAV License String. The MobileNAV License String can be ordered 

from your Dynamics 365 Business Central partner or from MultiSoft Ltd. 

To import the MobileNAV License String, do the following: 

1. Launch Dynamics 365 Business Central SaaS, and log in with your account 

2. Press ALT + Q for quick search MobileNAV Administration 
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3. Select “All Devices”  

 

 

4. Select “Process” -> “Change License” 

 

 
 

5. After confirming the message, a window opens where you can enter your MobileNAV License String 
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6. Enter your MobileNAV License String, and press OK 

7. Check the information section on the Device Management window, which shows information about 

your license 

 

 

 

7.2. Import MobileNAV Configuration 

In this step you will import the MobileNAV Configuration. You can import a custom configuration, which 

has been customized and exported in another environment (like dev or test system), or you can import the 

base configuration. 

1. Launch Dynamics 365 Business Central SaaS, and log in with your account 

2. Press ALT + Q for quick search MobileNAV Administration 
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3. Select “Configuration” -> “Configuration Handling” 

 
 

4. Select whether you want to import the base configuration, or you want to import a custom 

configuration 
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5. In case you have selected importing custom configuration, then you need to browse the 

configuration XML file 

 
 

6. The import of MobileNAV configuration will start 

 
 

7. Wait until the import finishes  

 

7.3. Set up MobileNAV users 

In this step you set up MobileNAV users. 

1. Launch Dynamics 365 Business Central SaaS, and log in with your account 

2. Press ALT + Q for quick search MobileNAV Administration 
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3. Select “Users” 

 

4. Press “New” 
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5. Select the already existing Dynamics 365 Business Central user for User ID column 

6. Select at least one profile for the user. MobileNAV base configuration contains thematic profiles 

separately for sales, service, warehouse, purchase, production, project, marketing and finance. For 

each profile, we have created an “online” and an “offline” version. The “online” version does not 

cache or download offline data (only certain lookup pages), so if the device loses the connection, 

then you cannot work. The “offline” version does download most of the offline data, but you need 

to optimize and filter the offline pages if necessary, otherwise the client app would download too 

much data.  

 

7. Fill out those columns which makes sense for the type of user you have selected 

a. Salesperson Code: for sales and marketing users 

b. Service Resource Filter: for field service users 

c. Location Code: for warehouse users 

d. GPS Tracking Enabled: for users whose GPS position should be reported to the server 

e. Movement Worksheet Name and Movement Journal Name: for warehouse users who are 

willing to use Ad-hoc Movement 
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f. Job Journal Template and Job Journal Batch: for project users 

8. Turn On or Off the Background Synchronization of MobileNAV for the user, or leave it on “By 

Client”, the mobile user can device it 

9. Select Login Mode for the user: 

 
 

a. By Client: the user can decide 

b. Online: the user will be forced to log into online mode always 

c. Offline: the user will be forced to log in offline mode always 

d. Online/Offline: the user can use both online and offline mode via using the Go Online or 

Go Offline in MobileNAV 

e. Auto Online/Offline: the user will be forced to use Auto Online-Offline mode, he cannot 

change these settings on his device. 

f. Strict Auto Online/Offline: the user will be forced to use Auto Online-Offline mode in strict 

mode, he cannot change these settings on his device. Strict mode means, that if the user 

has pending offline changes, which are not uploaded yet, then he is not allowed to execute 

any online feature. 

10. If you have selected Online or Auto Online/Offline as Login Mode, then you can also select 

Connection Status Monitoring Interval, which specifies how frequently should the MobileNAV app 

check the connection to the server, or you can leave it as “By Client”, so the user can set the value 

on the device. 

 

8. Import MobileNAV Configuration translations 
Import the translations of the configuration object. MultiSoft provides translations for the base 

configuration objects in many languages. If you imported the base configuration in the previous step you 

can import the translation for other languages.  
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8.1. Check installed languages 

As a preparation, check what installed language modules are available in your NAV system. Go to the Tools 

-> Language… menu in Development Environment to see the Application Languages list.  

 

For these languages you need to know the Language Code and the Windows Language ID. To check these 

codes, run the Language (8) table. 

 

  

If the installation package already contains the translations for your installed languages, then you can skip 

the next step. 
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8.2. Prepare translation files 

For example if you are having German (Swiss) language installed in your NAV system, then the Language 

Code will be DES, and the Windows Language ID is 2055. 

Since MultiSoft provides the translation for German language (DEU, 1031), you must adjust the translation 

text files before you try to import it for German (Swiss). Here are the steps for that: 

1. Find MobileNAV Config Translation file for DEU in the MobileNAV installation package. The 

filename is MobileNAV_Config_Translation_DEU.txt 

2. Open the file in Notepad. 

3. Click CTRL + H for Replace. 

4. For “Find what” enter “-A1031-”. This is the Windows Language ID of German. 

5. For “Replace with” enter “-A2055-”. This is the Windows Language ID of German (Swiss). 

 

6. Click Replace All. 

7. Go to File -> Save As… 

8. For filename set e.g.: MobileNAV_Config_Translation_DES.txt 

9. Find MobileNAV Category Translation file for DEU in the MobileNAV installation package. The 

filename is MobileNAV_Category_Translation_DEU.txt 

10. Open the file in Notepad. 

11. Press CTRL + H for Replace. 

12. For “Find what” enter “;DEU;”. This is the Language Code of German. 

13. For “Replace with” enter “;DES;”. This is the Language Code of German (Swiss). 
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14. Click Replace All. 

15. Go to File -> Save As… 

16. For filename, type MobileNAV_Category_Translation_DES.txt 

If you have prepared the translation files for all of your installed languages, you can start importing them. 

8.3. Import configuration translations 

For importing the configuration translations, do the following: 

1. Launch Development Environment client, and open the proper database and company. 

2. Open Object Designer (SHIFT + F12) 

3. Select the All category on the left panel. 

4. Apply Table Filter for the Version List field, and set “*MNCO*” as filter. 

5. Select all objects in the list. 

6. Go to the Tools -> Translate -> Import… menu. 

7. Browse to the configuration translation file and click Open. 
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The translation file will be imported. 

 

8. Click Yes to apply the translation. 

 

9. Check whether the translation has been successfully imported.  

a. Select for example, MN Customer Card (page: 42012940). 

b. Click Design. 

c. Find the Orders field name. 

d. Press SHIFT + F4 for properties. 

e. Verify that the field has the proper translation in the CaptionML property. 
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Repeat these steps for each installed languages that you have, except for English (United States), because 

the ENU translation is included in the configuration objects. 

8.4. Import category translations 

To import the configuration translations, do the following: 

1. Launch RTC client, and open the proper database and company. 

2. Go to Departments –> MobileNAV. 

3. Under Tasks/Periodic activities, select Category Translation Import. 

 

4. Leave Import selected. 

5. Browse to the MobileNAV Category Translation TXT file in the installation package, or what you 

have previously prepared. 
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6. Click Open. 

7. Verify that the translation of the categories have been successfully imported 

a. Go to Departments -> MobileNAV. 

b. Under Administration/Setup, select Categories. 

c. Select for example, SALES. 

d. Click Translation. 

e. The translation for Sales has to be there for the language you have imported previously. 

 

8.5. Refresh configuration 

After importing all translations, you must refresh the configuration, because the underlying pages have 

been updated previously. Here are the steps for this: 
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1. Launch RTC client, and open the proper database and company. 

2. Go to Departments -> MobileNAV. 

3. Under Tasks/Periodic activities, select Refresh all data for all configured pages. 

4. Confirm that warning message by clicking Yes. 

 

All pages will be refreshed. 

 

 

9. Generate Login Configuration XML for MobileNAV client (optional) 
Optionally, you can generate Login Configuration XML from the MobileNAV User Setup, and send that file 

to the client devices, so that the users can import it, and it will fill out most of the login parameters. 

1. Launch Dynamics NAV or Dynamics 365 Business Central, and log in with your account 

2. Press ALT + Q for quick search MobileNAV Administration 
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3. Select “Users” 

 

4. Press “Process” -> “Generate Login Configuration” 

 

5. Select the “Authentication Type”, and fill and correct the fields for the Login Configuration 
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6. Press “Generate Login Configuration File” button to generate the XML file 

7. If necessary, change the file extension to “.mnlc”  

8. Send the file to the mobile device 

 

10. Login with MobileNAV client application 
Verify that everything is properly installed and configured. You will log in from the MobileNAV application 

to your Dynamics 365 Business Central server. 

1. If you have chosen internal server with VPN connection, then first connect via VPN on the mobile 

device. 

2. Launch the MobileNAV client application. By default, the login configuration selector will show 

“<Demo server>” which you will connect to the MobileNAV demo servers, where you can check the 

latest base configuration of MobileNAV. 

 

3. Press the Login Configuration selector, which opens the Login Configuration list 

4. Press “Import” to import the Login Configuration XML you have generated in MobileNAV User 

Setup, or Press “New” to create a new Login Configuration 
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5. Depending on the Authentication Type of your Dynamics 365 Business Central, you can choose 

“User/Pw” or “O365”. 

a. In case of “User/Pw” you need to enter the following 

i. Enter the user name to one of the configured MobileNAV user’s login name. 

ii. Enter the password to one of the configured MobileNAV user’s password. 

iii. Enter the domain to your domain name. Leave it empty if you are using Business 

Central Authentication. 

b. In case of “O365” you need to enter the following: 

i. Enter the Tenant ID, which is the URL friendly name or the GUID of the Azure 

Active Directory. 

You can find this under  

• Azure Active Directory -> Properties -> Name (like: 
mobilenavtest2.onmicrosoft.com) or  

• Azure Active Directory -> Properties -> Directory ID (like: 351e143e-a0d2-
45c8-87a4-66c4aac5a966) 

 

 

 

ii. Enter the App ID, which is the Application ID (GUID) of the Native App registration 
of the Azure Active Directory. It is important that the App registration’s Application 
Type is Native, and not “Web app / API”. You can find this under Active Directory -> 
App registrations.  
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In case of Business Central SaaS, this App registration needs to have permission to 
“Dynamics 365 Business Central”. You can find this under Active Directory -> App 
registrations -> {Native App registration} -> Settings -> Required permissions. 

 

 

 

In any other case, this App registration needs to have permission to a “Web app / 
API” type App registration. You can find this under Active Directory -> App 
registrations -> {Native App registration} -> Settings -> Required permissions. 
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iii. Enter Redirect Uri, which is (one of) the Redirect URI of the Native App registration 
specified in App ID. You can find this under Active Directory -> App registrations -> 
{Native App registration} -> Settings -> Redirect URIs. The Redirect URI can be 
anything, like “https://mobilenav.com”. 

 

 

 

iv. Enter App ID Uri, which is the App ID Uri of the “Web app / API” type App 
registration.  

• In case of Business Central SaaS, there is a built-in “Web app / API” App 
registration, and you need to enter: 
“https://api.businesscentral.dynamics.com” 

• In case of any other type of NAV, you have a “Web app / API” type App 
registration, and you can find this information under: Active Directory -> 
App registrations -> {Web app /API App registration} -> Settings -> 
Properties -> App ID Uri. 

 

 

 

 

6. Check the Use SSL option if you have configured the server’s SOAP web services with SSL 

encryption. 

7. Enter the server and the port address of your server’s SOAP web service. Please note that if you 
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choose to use internal server with port forwarding, then you need to replace the computer name 

with the external address. 

8. Enter the instance to the instance name you have set for server. 

9. Enter the company to the company name that you want to connect to. 

     

10. Press Save to save the Login Configuration. At this point MobileNAV will test the connection to the 

server. If the credentials you have provided are proper, then the new Login configuration will be 

stored and selected, and you will go back to the Login screen automatically. 

 

 
11. Click Login. 

12. Wait until the login takes place. 
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13. Verify that you have successfully logged in. 
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Typical errors during log in include the following: 

- Invalid credentials: the user name, password or the domain that you have entered is invalid. 

- Connection to the server failed: the SSL, server, or port that you have entered is invalid. 

- Invalid instance name: the instance name that you have entered in invalid. 

- Invalid company name or the server is not MobileNAV compatible: the company name that you 

have entered is invalid or the MobileNAV solution is not properly installed and configured. 

 

 Uninstalling MobileNAV solution 

1. Uninstall MobileNAV Component setup 
MobileNAV has a separate DLL component for licensing. This component must be uninstalled from the PC 

where the Service Tier is installed and running. Furthermore, you also need to uninstall from the PCs where 
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you have installed the MobileNAV component DLL for the Development Environment.  

To uninstall the MobileNAV component, follow the instructions below: 

1. Go to Add or remove programs 

2. Find the “MobileNAV Components”, and press Uninstall 

 
3. Wait until the uninstall finishes 

1. Delete MobileNAV objects 
In order to successfully remove the MobileNAV Add-on objects, you need to delete all objects within the 

MobileNAV object range 42012822..42013162. 

To delete all MobileNAV Add-on range objects, follow the instructions below: 

1. Open the Development Environment 

2. Open Object Designer 

3. Filter for objects, where ID = 42012822..42013162 

4. press Delete with Force option 

2. Un-merge or restore original standard objects 
All standard objects modifications do not require any MobileNAV related objects. They will continue to 

compile even without any single MobileNAV objects. These modifications are only in order to use a certain 

functionality from NAV web service. So it is not necessary to remove these changes, but if you still want to 

do so, then either restore the original standard object modification, or remove the changes manually 

according to the comments. 

 Backup and Restore 

MobileNAV does not have any external configuration file or data, so the standard Dynamics NAV backup 

and restore is enough. 

 Hardware requirements 
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Since MobileNAV does not have any separate server side component, and it is just a light-weight Add-on of 

Dynamics NAV, its hardware requirements matches with the hardware requirement of the Microsoft 

Dynamics NAV product. 

 


